This site is in archival mode. A replacement is being developed. In the meantime, please use the PBW2 Forums for community discussions. The replacement software for this site will use a unified account system with PBW2, and any newly created threads will carry over.
Welcome to Spaceempires.net
Login or Register

Search
Modules
· Content
· Downloads
· Forums
· Game Info
· Image Gallery
· Links
· Shipyards
· Topics
· Staff

User Info
· Welcome, Anonymous
Membership:
· New: Astorre
· New Today: 0
· New Yesterday: 0
· Overall: 3155

People Online:
· Visitors: 101
· Members: 0
· Total: 101

  

Spaceempires.net :: SE5 + Windows 7 :: View topic
Forum FAQ :: Search :: Memberlist :: Usergroups :: Profile :: Log in to check your private messages :: Log in


SE5 + Windows 7
Goto page 1, 2, 3, 4, 5  Next
 
Post new topic   Reply to topic    Spaceempires.net Forum Index -> SEV Spaceport
View previous topic :: View next topic  

Operating system you use for SE5?
Windows XP
36%
 36%  [ 42 ]
Windows Vista
16%
 16%  [ 19 ]
Windows 7
45%
 45%  [ 52 ]
Other (Wine etc)
0%
 0%  [ 1 ]
Total Votes : 114

Author Message
ashwaker
Space Emperor


Joined: Sep 29, 2009
Location: Amenti

PostPosted: Wed Dec 02, 2009 10:43 am    Post subject: SE5 + Windows 7 Reply with quote

Hi again,

I have been trialling SE5 (Steam edition) under Windows 7 and the results are interesting. For one thing, the game's performance with no compatibility mode + no vsync on my PC is unexpectedly high in parts and sluggish in others. I would like to start a discussion about possible fixes for certain performance flaws in the running of the game.

PC Details:
CPU - Core 2 Duo E8200 @ 2.66Ghz
RAM - 2GB of 667Mhz DDR2
HDD - 500GB SATA, 7200RPM
GFX - Palit nVidia 9800GT 512MB RAM displaying 1440x900 (16 bit colour for se5)
Windows 7 Aero was completely disabled (Classic themes used and all aesthetic graphic elements disabled via Computer Properties Advanced System Settings section)

Now, on XP I got around 20-40fps on all screens, the only lag being when I had selected a sector with many ships, as well as during combats. I was using vsync and triple filtering. The game was, for all intents and purposes, completely playable. I also changed the setting of "Maximum Pre-Rendered Frames" in the nVidia Control Panel to 0, as per a post I had read over on spaceempires5.com about it.

Then, on 7, without using any compatibility mode, and again with vsync, triple filtering and Max Pre-Rendered Frames at 0, FPS is slightly decreased. However, performance of certain elements is different to XP. In particular, strategic combat is slower. The Ships window also takes approximately five to ten times to load, making this feature of the game completely unusable. Other list-based windows are slower, but none so much as the Ships window.

When I tried to use XP compatibility mode on SE5, Steam reported that the game was "unavailable at this time". Trying the game in Vista compatibility mode yielded negligible or no difference to the standard running of the game.

I have tried the game on 7 without vsync or triple filtering. When these elements are not used, the game's fps is not regulated, which for my computer had the effect of a much faster yet more jittery system display. The Ships window was still completely unusable.

When Aero was enabled at all, the game would intermittently flash white.

I would like to hear any possible experiences others have had with Win7 and SE5. For the PBW game I am in, the game is playable for now, but with the single-player game I had going, it is not. Why did Malfador use such a strange, picky graphics system for the game, I'll never know.


Everybody! Every *single* person that you or I has ever known is dead! Dead!


Back to top
Feygan
Space Emperor


Joined: Aug 02, 2007

PostPosted: Wed Dec 02, 2009 11:49 am    Post subject: Reply with quote

To be honest performance issues is something I've never suffered with on SEV in any windows, and I've used xp, vista, and 7. Granted I do have a fairly powerful machine thats designed for new games, but still never any problems at all regarding frame rates. I do get the long turn time issues however I play large system quadrants with ship limits in the 2000 so thats my fault.

The white flickering I do get too, however I found this to be due to outside programs, I use opera for web browsing, if thats open while playing SEV then each time it checks for email I get flickering. If I have a download running then when that finishes I get flickering. It happens if I get an alert from either my spyware or virus software. In fact anytime you get a pop up message on my taskbar SEV flickers.


Back to top
Kontana
Space Emperor


Joined: Jul 02, 2009
Location: Planet Hyrule, of the Hyrulian Federation

PostPosted: Wed Dec 02, 2009 2:46 pm    Post subject: Reply with quote

I don't have Win7 or Vista, so can't really help with issues with those. One option is to setup the computer to dual boot, so you can still run WinXP to play SEV, and use Win7/Vista to do other things.

Kontana's UI Mod | BM1.19-Ship Space Comparison


Back to top
bearclaw
Space Emperor


Joined: Aug 04, 2003
Location: BC, Canada

PostPosted: Wed Dec 02, 2009 5:21 pm    Post subject: Reply with quote

I recently upgraded my computer from Vista x64 to Win7 x64 and the difference it tremendous!

On Vista, I had to turn off all sorts of the details and ClearType etc, and it was usable but with significant screen flicker. Once I upgraded to Win7, i didn't have to do any of that. I'm not runing the graphic options at their highest settings, but they are at least on and it works great!

Soooo glad I upgraded to Win7 just for this Smile


Nick (bearclaw)

"You don't know the Power of the Dark Side. I must obey my Master"


Back to top
TheThirdEye
Space Emperor


Joined: Mar 22, 2009
Location: Toronto

PostPosted: Thu Dec 03, 2009 1:57 am    Post subject: Reply with quote

Don't have Vista or 7 so can't really say about those.

The Dual Boot is a Wonderful option for many things.
Recently I've been playing else where so I don't have DB setup at the moment, so I'm only using XP, which works quite well for SEV.
Normally I use 98, which works Even Better. 40-60% faster for almost everything in the game, except turn processing, which is only about 25% faster.

Consider 'upgrading' to a 98 Dual Boot setup. Doesn't take much space for 98 and SEV (not setup right now, so can't give exact numbers).


Back to top
TheChin
Space Emperor


Joined: Nov 07, 2008
Location: Cleveland, Oh

PostPosted: Fri Dec 04, 2009 1:17 pm    Post subject: Reply with quote

I got the white flashing in XP, until I set SEV to Safe for video memory, then it disappeared. This was just on my laptop, on my PC (also XP) I never got white flashing, so it might be more a function of video card/drivers.

Back to top
ashwaker
Space Emperor


Joined: Sep 29, 2009
Location: Amenti

PostPosted: Tue Dec 08, 2009 4:57 pm    Post subject: Reply with quote

I installed a dual-boot system after observing all the evidence clearly stacked against not using XP.

The performance of XP makes the game much more enjoyable.
Although I definitely would like to see a retrofit of the game - as a patch or a future incarnation of the series - I think Malfador has run dry on the series.

I heard about Starfury 2 "back in the day"... perhaps it will be used again to test 3D skills, hopefully DX10/11 this time Very Happy

Thanks for all your input. It's an interesting topic for me.


Everybody! Every *single* person that you or I has ever known is dead! Dead!


Back to top
orionc
Space Emperor


Joined: Dec 22, 2008

PostPosted: Fri Dec 11, 2009 7:04 am    Post subject: Reply with quote

my problem is i cant get the game to install at all. i have windows vista home premium with an amd phenom quad core and an Nvidia geforce 9100.

Back to top
ForesterSOF
Space Emperor


Joined: Jun 23, 2007

PostPosted: Fri Dec 11, 2009 8:05 am    Post subject: Reply with quote

Do you have a co;y of the game some where.

I have made a copy of my SEV at times so I can play multiple versions of a mod or the game itself.

I had to start the game with the exe of desktop shortcut but all the needed links seemed to be there.


Back to top
orionc
Space Emperor


Joined: Dec 22, 2008

PostPosted: Fri Dec 11, 2009 6:43 pm    Post subject: Reply with quote

I have the CD yes

Back to top
ForesterSOF
Space Emperor


Joined: Jun 23, 2007

PostPosted: Fri Dec 11, 2009 9:24 pm    Post subject: Reply with quote

The copy I am talking about is a direct copy of what was put on my Hard Disk.

Back to top
orionc
Space Emperor


Joined: Dec 22, 2008

PostPosted: Wed Dec 16, 2009 9:36 pm    Post subject: Reply with quote

well i suppose i could put a copy of the game file on my thumbdrive, would that allow me to play the game on my windows vista machine?

Back to top
Skyburn
Space Emperor


Joined: Mar 12, 2008

PostPosted: Wed Dec 16, 2009 10:41 pm    Post subject: Reply with quote

It would need to be an installed copy that was moved onto the thumb drive.

Do you get an error message when you try to install SE5?


Back to top
orionc
Space Emperor


Joined: Dec 22, 2008

PostPosted: Thu Dec 17, 2009 12:50 am    Post subject: Reply with quote

wow it just installed! ill let you know how it plays.

Back to top
orionc
Space Emperor


Joined: Dec 22, 2008

PostPosted: Thu Dec 17, 2009 1:09 am    Post subject: Reply with quote

it seemed to play fine, but windows told me the video game was missing a part, it was missing "D3DRM.dll"

Back to top
Mentat
Space Emperor


Joined: Jan 04, 2010

PostPosted: Mon Jan 04, 2010 6:20 pm    Post subject: Reply with quote

Well it seems Win7 is far better performer than Vista SP2.

I have a vista laptop with;
Intel T9550 2.66 Gz
Nvidia 9600GT
4 Gig Ram

and a Win7 laptop with;
Intel T6600 2.2 Gz
Ati HD 4330
4 Gig ram

and Win7 definitely performs better with SEV despite having far inferior specs than the Vista pc.

I can easily get 80 FPS on map screen and 30 FPS on ship design screen with it.

with Vista , I can get barely 30 FPS on map screen and 10 FPS on ship design screen.

Settings are:

windowed mode
1024x768x32
Graphics : Low
Backgrounf: Low

I almost tried everything to get vista working but its a no go.
it is even bogged down further after opening a few menus in game.

I dont know why but i am definitely frustrated with it. I wonder if programmers are sleeping still? there are tens of patches released and none of them addresses this damn problem!

PS> These values are with clear type font is removed. But its still playable with Win7 without removing this feature and its still 50 FPS in map screen and 20 FPS in ship design screen


Back to top
marhawkman
Space Emperor


Joined: Mar 24, 2008

PostPosted: Tue Jan 05, 2010 1:15 am    Post subject: Reply with quote

Hmm... there are some system settings you can tweak in Vista to help that. Mostly disabling useless memory wasting background processes.

Back to top
Mentat
Space Emperor


Joined: Jan 04, 2010

PostPosted: Tue Jan 05, 2010 3:08 pm    Post subject: Reply with quote

They are already tweaked. You are talking indexing services and such i guess..

its a blazing fast laptop with everything else. But SEV is a no go.


Back to top
bearclaw
Space Emperor


Joined: Aug 04, 2003
Location: BC, Canada

PostPosted: Tue Jan 05, 2010 5:30 pm    Post subject: Reply with quote

I came across this interesting article this morning. Thought it might be of interest for anyone wanting a one-stop place for all the tweaks available in Win7 (and 32-bit Vista, apparently)

Quote:
"The “God Mode” folder for Windows 7 supplies a tidy place to find nearly everything you can do within the Windows Control Panel.
To access the special capabilities of the God Mode folder, create a new folder anywhere on your Windows 7 computer and name it:

GodMode.{ED7BA470-8E54-465E-825C-99712043E01C}

Once renamed, the icon will change to a control panel looking icon, and when opened you will be presented with a plethora of different tweaking options. On my Windows 7 Professional machine, I was shown 274 options. It appears to hold the main keywords for each option to use the search function within the control panel.
Word has it that this hack also works on Vista 32-bit, but crashes on 64-bit versions."


Nick (bearclaw)

"You don't know the Power of the Dark Side. I must obey my Master"


Back to top
Fyron
Galactic Guru


Joined: Aug 04, 2003
Location: CA, USA

PostPosted: Tue Jan 05, 2010 5:54 pm    Post subject: Reply with quote

Boy oh boy does that fuck up explorer in Vista64!

Smarter than your average Texrak.


Back to top
bearclaw
Space Emperor


Joined: Aug 04, 2003
Location: BC, Canada

PostPosted: Tue Jan 05, 2010 6:07 pm    Post subject: Reply with quote

LOL!
You just had to try it, eh? Even with it saying it crashes 64-bit Vista Smile


Nick (bearclaw)

"You don't know the Power of the Dark Side. I must obey my Master"


Back to top
marhawkman
Space Emperor


Joined: Mar 24, 2008

PostPosted: Tue Jan 05, 2010 7:29 pm    Post subject: Reply with quote

Mentat wrote:
They are already tweaked. You are talking indexing services and such i guess..

its a blazing fast laptop with everything else. But SEV is a no go.
And stuff like the "Desktop cleanup" wizard that runs whether you need it to or not.

Back to top
Fyron
Galactic Guru


Joined: Aug 04, 2003
Location: CA, USA

PostPosted: Tue Jan 05, 2010 8:54 pm    Post subject: Reply with quote

bearclaw wrote:
LOL!
You just had to try it, eh? Even with it saying it crashes 64-bit Vista Smile

You can't learn anything about a complex piece of software without breaking it!

The OS itself was fine; I just had to open up a WinRAR instance with the task manager to delete the offending folder/applet/shortcut thing, since it cause Explorer to crash and burn every time it restarted. For some reason access was denied when I tried to delete it with cmd...


Smarter than your average Texrak.


Back to top
AndreyKl
Space Emperor


Joined: Jan 08, 2010

PostPosted: Fri Jan 08, 2010 10:01 pm    Post subject: Reply with quote

SEV works nice at win7 exept generating different lists like were said in first post. Big problem with fllet lists, just long load of colonies, systems e t c

Back to top
Battlespud
Space Emperor


Joined: Mar 24, 2008

PostPosted: Sun Jan 10, 2010 3:35 pm    Post subject: Reply with quote

I don't really understand why people have such an issue running SEV on Vista. I have 3 vista machines, 2 laptops and a desktop and there is no visible lag whatsoever, or slow down, on highest settings on any of them.

stats
Desktop:
AMD Phenom x4 2.2GHZ
ATI Radeon OC PCS+ 4890 (1 gig)
7 gigs Dual Channel DDR2
1 TB HDD
650 watt OCZ StealthXstream
Vista 64 bit Premium

Laptops: (same stats on each)
2 GHZ AMD Turion
Nvidia 7300LE (GREAT for the money, even runs Empire Total War decently and any of the older ones like Med II maxed!)
200 gig HDD
Vista 64 bit Premium

It makes no sense that people are getting such varying results.


Back to top
Display posts from previous:   
Post new topic   Reply to topic    Spaceempires.net Forum Index -> SEV Spaceport All times are GMT
Goto page 1, 2, 3, 4, 5  Next
Page 1 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
All logos and trademarks used on this site, all comments and stories posted for reading, all files hosted for download,
and all art work hosted for viewing are property of their respective owners; all the rest copyright 2003-2010 Nolan Kelly.
Syndicate news: SpaceEmpires.net News RSS Feed - Syndicate forums: SpaceEmpires.net Forums RSS Feed
Page Generation: 0.20 Seconds